Disruptive Technology integration - Minor Synchronization Discrepancy

Incident Report for Neowit

Resolved

The issue is now resolved. After implementing a fix, we monitored system performance and conducted testing to ensure stability. All services are operating normally.
Posted Mar 27, 2026 - 12:56 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2026 - 21:09 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 26, 2026 - 20:30 UTC

Investigating

We are currently investigating a minor discrepancy in event updates from Disruptive Technologies. While the vast majority of synchronizations are completing successfully, a small subset of events are missing.
Posted Mar 25, 2026 - 12:00 UTC
This incident affected: Integrations (Disruptive Technologies).